Back to overview
Degraded
DNS failure
Apr 11 at 08:00am CEST
Affected services
hayze.xyz - main website
Resolved
Apr 11 at 09:00am CEST
DNS is back in operation. Thank your for your patience.
Affected services
Created
Apr 11 at 08:00am CEST
We are experiencing some issues with our DNS. Please stand by as we will look into this issue.
Affected services