Back to overview
Downtime
Cloudflare - error 521
Apr 11 at 09:40pm CEST
Affected services
hayze.xyz - main website
Resolved
Apr 11 at 09:52pm CEST
The issue has been resolved - SSL error.
Affected services
Created
Apr 11 at 09:40pm CEST
We are currently looking into the issue, please stand by.
Affected services